在 Ubuntu 19.04中,安装 MySQL Workbench

・1 分钟阅读

问题:

我试图通过以下方式安装 MySQL Workbench:


 apt-get install mysql-workbench-community



但是,我遇到以下错误,无法手动安装:


Depends: libssl1.0.0 (>= 1.0.2~beta3) but it is not installable


Depends: libzip4 (>= 0.10) but it is not installable




回答 1:

即使你检查了下载站点( https://dev.mysql.com/downloads/workbench/ ),你也不会看到 19.04发布的版本。 看来我们得等版本发布了。 这完全是一个无赖。

我也可以确认 18.10安装程序在 19.04上不工作


回答 2:

我通过安装libzip包来解决这个问题,直接从deb包中。 我发现在 https://ubuntu.pkgs.org/18.10/ubuntu-universe-amd64/libzip4_1.1.2-1.1_amd64.deb.html 。 从apt或deb包下载并安装 libzip4,无论你喜欢哪种,都可以安装。


讨论
Tianye profile image