在Debian 9上如何安装PyroCMS

・8 分钟阅读

使用不同的系统?

pyroCMS是一个用PHP编写的开源CMS ,PyroCMS源代码托管在gitHub ,在本指南中我们将介绍Debian9实例上的整个Pyrocms安装进程。

要求

在服务器上安装PyroCMS之前,需要满足一些要求。

  • 1GB内存
  • PyroCMS支持Apache或nginx,但是,我们会使用LEMP堆栈,
  • PHP版本7.0或更高版本
  • 以下PHP扩展:
    • PDO
    • cURL
    • SQLite
    • OpenSSL
    • Mbstring
    • Fileinfo
    • Tokenizer
    • GD库2.0或更高版本,Imagick PHP扩展6.5.7或更高版本)

开始之前

查看Debian版本。


lsb_release -ds
# Debian GNU/Linux 9.4 (stretch)

确保你的系统是最新的。


apt update && apt upgrade -y

安装必要的软件包。


apt install -y sudo unzip apt-transport-https curl wget dirmngr

使用sudo访问创建一个新的non-root用户帐户,并且切换到它。


adduser johndoe --gecos"John Doe"
usermod -aG sudo johndoe
su - johndoe

注:将johndoe替换为你的用户名。

设置时区。


sudo dpkg-reconfigure tzdata

安装PHP和所需的PHP扩展

下载并安装PHP 7.0和所需的PHP扩展。


sudo apt install -y php7.0 php7.0-cli php7.0-fpm php7.0-mysql php7.0-curl php7.0-sqlite3 php7.0-mbstring php7.0-gd php7.0-xml

检查版本。


php --version

# PHP 7.0.27-0+deb9u1 (cli) (built: Jan 5 2018 13:51:52) ( NTS )
# Copyright (c) 1997-2017 The PHP Group
# Zend Engine v3.0.0, Copyright (c) 1998-2017 Zend Technologies
# with Zend OPcache v7.0.27-0+deb9u1, Copyright (c) 1999-2017, by Zend Technologies

安装MariaDB

下载并安装MariaDB 。


sudo apt install -y mariadb-server

检查版本。


mysql --version
# mysql Ver 15.1 Distrib 10.1.26-MariaDB, for debian-linux-gnu (x86_64) using readline 5.2

运行mysql_secure_installation脚本以提高MariaDB安装的安全性。


sudo mysql_secure_installation

# Enter current password for root (enter for none):

# Set root password? [Y/n] Y
# New password: ******************
# Re-enter new password: ******************
# Remove anonymous users? [Y/n] Y
# Disallow root login remotely? [Y/n] Y
# Remove test database and access to it? [Y/n] Y
# Reload privilege tables now? [Y/n] Y
# Success.

# All done!

以root用户身份登录到MariaDB 。


sudo mysql -u root -p
# Enter password:

创建新的MariaDB数据库和用户,并记住凭据。


create database dbname;
grant all on dbname.* to 'username' identified by 'password';
flush privileges;

退出MariaDB 。

 
exit

 

安装Nginx

安装Nginx 。


sudo apt install -y nginx

检查版本。


sudo nginx -v
# nginx version: nginx/1.10.3

将Nginx配置为FastCGI代理,运行 sudo vim /etc/nginx/sites-available/pyro.conf 并使用以下配置。


server {
 listen 80;

 server_name example.com; # Check this
 root /var/www/pyro/public; # Check this

 index index.php index.html;
 charset utf-8;

 location / {
 try_files $uri $uri/ /index.php?$args;
 }

 location ~ .php$ {
 fastcgi_pass unix:/var/run/php/php7.0-fpm.sock; # Check this
 fastcgi_index index.php;
 fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
 include fastcgi_params;
 }

}

注意:请确保将web root指向Pyro目录的public

通过将文件链接到sites-enabled目录来激活新的pyro.conf配置。


sudo ln -s /etc/nginx/sites-available/pyro.conf /etc/nginx/sites-enabled/

测试Nginx配置。

 
sudo nginx -t

 

重新加载Nginx 。


sudo systemctl reload nginx.service

下载和安装Composer

如果系统中还没有Composer依赖项,则下载它们。


sudo apt install -y curl git unzip

下载,并且安装Composer,PHP的依赖项管理器。


php -r"copy('https://getcomposer.org/installer', 'composer-setup.php');"
php -r"if (hash_file('SHA384', 'composer-setup.php') === '544e09ee996cdf60ece3804abc52599c22b1f40f4323403c44d44fdfdd586475ca9813a858088ffbc1f233e9b180f061') { echo 'Installer verified'; } else { echo 'Installer corrupt'; unlink('composer-setup.php'); } echo PHP_EOL;"
php composer-setup.php
php -r"unlink('composer-setup.php');"
sudo mv composer.phar /usr/local/bin/composer

检查Composer版本。


composer --version
# Composer version 1.6.5 2018-05-04 11:44:59

通过Composer下载并安装PyroCMS

创建文档root目录。


sudo mkdir -p /var/www/pyro

/var/www/pyro目录的所有权更改为johndoe


sudo chown -R johndoe:johndoe /var/www/pyro

从命令行下载最新稳定版本的PyroCMS


cd /var/www/pyro
composer create-project pyrocms/pyrocms .

注意:通过Composer安装Pyro时,你可能内存不足,停止Nginx ,php-fpm和MySQL服务器可能是明智 sudo systemctl stop nginx.service php7.0-fpm.service mariadb.service 保存内存使用情况,并且在此步骤后再次启动它们,如果这不能帮助你避免使用Composer出错,那么你需要设置交换

/var/www/pyro目录的所有权更改为www-data


sudo chown -R www-data:www-data /var/www/pyro

使用你喜欢的网络浏览器,打开你的网站,并且遵循Pyrocms安装程序,按照安装程序后你会启动,并且运行PyroCMS ,要访问PyroCMS管理区域只需将/admin附加到你的站点URL。

Haojinghui profile image