在Debian 8或Ubuntu 16.04上使用EasyEngine在几分钟内安装Nginx,Wordpress和Let\'s Encrypt

・2 分钟阅读

EasyEngine (ee )是一个轻松且自动地在Nginx上管理你Wordpress站点的python工具,使用EasyEngine,你就不必处理复杂的web服务器配置。

在这个简单的指南中,我们将看到如何安装EasyEngine,并设置一个使用let's Encrypt证书的HTTPS的WordPress站点。

为什么用EasyEngine?

  • Complete Setup :使用单个命令安装Nginx,MySQL,Postfix,PHP 7和依赖项,
  • Let's Encrypt :在创建站点或之后使用简单标记--letsencrypt启用HTTPS (SSL/TLS ),
  • Caching Options :使用W3Total缓存,WP Super Cache和NginxFastCGI缓存 ,

前提条件

  • 新部署的Debian 8或Ubuntu 16 04服务器实例,
  • 一个sudo用户

安装

EasyEngine必须安装在尚未安装Apache或MySQL的新服务器上。

更新系统。

 
sudo apt-get update

 

安装EasyEngine 。


wget -qO ee rt.cx/ee && sudo bash ee

你将被要求输入用户名和电子邮件地址,安装完成后,检查它是否正常工作。

 
sudo ee

 

你将收到可用参数的列表。

运行EasyEngine

EasyEngine旨在简化Wordpress的安装 - 只需一个命令即可完成。


sudo ee site create yourdomain.com --wp --letsencrypt

此命令将安装let's Encrypt证书,Nginx,PHP和MariaDB,然后安装WordPress 。

你可以在-wp之后添加其他参数,在easyEngine网站 查看可用的命令列表。

杨和超 profile image